downloadable products dissapear after upgrading from free to pro

Posted by: Filip

8th February 2018, 8:44 pm

Filip

@Downit

8 Feb 2018
8:44 pm

Hi, this is a live site for a client, so we had to switch back to the free version as soon as we noticed the products not showing up.

Is it possible that the latest pro version works only with a woocommerce version more recent than xxx ? It's true we're running an older version, as we're upgrading as little as possible here, due to general complexity and custom coding of this site. (2.6.14)

Thanks!

  • Developer
    Richard Webster

    @rwebster

    8 Feb 2018
    9:11 pm

    Hi mate the plugin only works with the latest WooCommerce, and the free version has only worked with WooCommerce 3.0+ since April last year. If you're running any version of the plugin since April last year it's the same code.

  • Developer
    Richard Webster

    @rwebster

    8 Feb 2018
    9:17 pm

    I could see about testing it with that version of Woo though, maybe theres some backwards compatibility I can build in.

  • Filip

    @Downit

    9 Feb 2018
    11:22 am

    hi! The free version running correctly on that older WC version is 2.4.3

    Since we're not upgrading that site within the first 6 months, it would be useful surely to have a look at that backwards compatibility. The only thing we need of the pro is the 'tracked downloads' page, nothing else that isn't on the free version.
    Perhaps an early version of the pro version could work?
    Thanks a lot!

  • Developer
    Richard Webster

    @rwebster

    9 Feb 2018
    12:11 pm

    I'll take a look at it mate. Leave it with me for a few days.

  • Developer
    Richard Webster

    @rwebster

    9 Feb 2018
    10:27 pm

    Pretty sure I've made the free version compatible now (not live, in testing). Will do the pro this weekend.

  • Developer
    Richard Webster

    @rwebster

    10 Feb 2018
    12:45 am

    Hi Filip download the latest version (1.0.91), this should work with your version of WooCommerce.

  • Filip

    @Downit

    10 Feb 2018
    2:15 pm

    Hi Richard, I confirm it's working fine, great!
    Perhaps you can advice on following issue: on the product archive page we have the 'download PDF' buttom below each product. When you click that, you come to the product detail page with the same download button to finally access the PDF. Thing is, the log counts that as two downloads, not just one.
    Client wants to keep the product detail pages, and preferably also the 'download pdf' button on archive pages. Is it possible somehow?

    Thanks a million for your fast fix!

  • Developer
    Richard Webster

    @rwebster

    10 Feb 2018
    2:18 pm

    Hi mate if you send me links to the site I can have a look at what's going on. Open a support ticket and send me URLs and an admin login as well.

This topic is closed to new replies.