Get New Password Button Not Working

Posted by: dpuffer

2nd July 2020, 10:56 pm

dpuffer

@dpuffer

2 Jul 2020
10:56 pm

Hi,

I'm experiencing a weird situation when my users reset their password and click a "Get new password" button it doesn't do anything at all.

I looked at the system console to see if any errors are occurring and I'm not getting anything.

Any ideas?

Thank you!

  • Developer
    Richard Webster

    @rwebster

    3 Jul 2020
    8:38 am

    Hi mate what's the website?

  • dpuffer

    @dpuffer

    3 Jul 2020
    7:41 pm

    Thank you for the reply,

    firstspindjs.com

  • Developer
    Richard Webster

    @rwebster

    3 Jul 2020
    7:55 pm

    I can see you're using Paid Memberships Pro. That plugin already handles user login and password reset from the frontend. There's probably a conflict somewhere.

  • dpuffer

    @dpuffer

    3 Jul 2020
    8:35 pm

    Im fairly new to using Paid Memberships Pro, I couldn't find any functionality of frontend password reset hence why I downloaded your plugin. What's weird is, it was working about 2 weeks ago just fine. Then one random day it stopped working.

  • Developer
    Richard Webster

    @rwebster

    3 Jul 2020
    8:40 pm

    Maybe the last update the did changed something mate. Either way it seems you don't need to use this one šŸ™‚

  • Developer
    Richard Webster

    @rwebster

    4 Jul 2020
    6:56 am

    I just noticed you also have WooCommerce installed, which also handles frontend password resets.

  • Abbasoftwp

    @Abbasoftwp

    13 Jul 2020
    10:00 am

    I installed frontend reset password plugin on my website (web.nnngo.org) and gave this error message 'The e-mail could not be sent.'.

    kindly hep me out

  • dpuffer

    @dpuffer

    13 Jul 2020
    11:27 pm

    I managed to get the button to work, I'm guessing it was a plugin conflict.

    But now its not sending the email to the user.

  • dpuffer

    @dpuffer

    13 Jul 2020
    11:31 pm

    I checked the mail log using WP Mail Logging Log and the email says it's being sent out but when clicked on the reset link it gives a 404 page

    any suggestions?

  • Developer
    Richard Webster

    @rwebster

    14 Jul 2020
    12:11 am

    You could check your settings again but like I said above you've got multiple plugins interacting with the same systems that mine does, and you don't even need this plugin. WooCommerce has my plugin functionality built in.

    Last modified: 14th July 2020, 12:11 am by Richard Webster