Sorry, this product cannot be purchased.

Posted by: Dan Turner

24th January 2021, 4:19 am

Dan Turner

@dturner87

24 Jan 2021
4:19 am

I'm attempting to use this plugin with the Fuel Themes/Peak Shops theme, but whenever I select "Download Now" it gives me the following error: "Sorry, this product cannot be purchased."

Unfortunately, I'm on a test environment, so I'm unable to share the link.

  • Developer
    Richard Webster

    @rwebster

    24 Jan 2021
    7:59 am

    Last modified: 24th January 2021, 7:59 am by Richard Webster

  • Dan Turner

    @dturner87

    24 Jan 2021
    2:24 pm

    Thanks for your help.  It is very similar behavior.  I disabled the ajax add to cart functionality on the site, and that resolved the issue

    I tried adding your custom function, but that didn't seem to work, but I'm satisfied with just disabling the ajax functionality.

    Thanks for your help.

  • Developer
    Richard Webster

    @rwebster

    25 Jan 2021
    3:41 am

    Yea that's what I was thinking. Removing one of the default classes with my snippet, which I include for CSS styling reasons with some themes, can be picked up by scripts.

    In your case it seems your theme is just overriding the button action regardless, which is something I can't prevent.

    At least you can disable the AJAX feature and get it working 🙂

This topic is closed to new replies.